EGO website not fully operational

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: cs

Have tried several times on different Windows 10 machine with the same results (either IE, Edge or Firefox).  1) tabs cannot be activated when looking at a specific product. 2) unable to select product for registration.  And that's only for now...

The only way I found to browse your website was using a Mac.  You better revise your html code and test it on different OS (make it HTML 5.0 compatible).  It's frustrating and I'm sure that I'm not the only one.
Photo of Michel Levesque

Michel Levesque

  • 270 Points 250 badge 2x thumb

Posted 3 years ago

  • 2
Photo of Harry

Harry

  • 2,802 Points 2k badge 2x thumb
Just checked several tabs on web site. No problems. Everything came up as expected. Using W10 Pro.
Photo of Michel Levesque

Michel Levesque

  • 270 Points 250 badge 2x thumb
I'm using W10 pro too and was forced to go on a Mac to register my new snow blower.  Have 5 different W10 machines at home and none are able to use the tabs (even with IE, Edge or Firefox).  Is there any plugin to activate?
Photo of fjp999

fjp999

  • 92 Points 75 badge 2x thumb
I was having some really odd behavior as well.

At first I couldn't login. When I call CS to register my replacement snowblower I mentioned the issue and CS said they were hearing of issues with the site and to give it a day or so.

I was able to login but the site thought I was on an iPhone (or iOS device) while I was on a MacBook Pro.

The odd way I was able to fix it was by accident - I went to my other MBPro & found an email link ... hit the link and it opened the forum with login and proper formatting! Tried it on the first MBPro and success as well!

Not sure if it will work with your Windows set up but worth a try.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 80,888 Points 50k badge 2x thumb
Hi Michel, thanks for writing in about this issue. Were you able to register your product or did you still need help? We can help you get this taken care of.
Photo of Michel Levesque

Michel Levesque

  • 270 Points 250 badge 2x thumb
Hi Jennifer, I was able to register my products but only using a Mac.  I've 5 Windows 10 PC at home and everyone cannot une the tabs on your website.  I've also tried at work with a Windows 10 pc and... same issue.
Photo of Ken

Ken

  • 60 Points
I can confirm there are login issues on Win 10 Pro using Microsoft Edge.  IE 11 appears to work fine as does the latest Chrome browser.  
Photo of Michel Levesque

Michel Levesque

  • 270 Points 250 badge 2x thumb

Login is not the main issue.  Using tabs on webpage is the worst.  Right now I'm logged but still unable to register my mower... frustrating

Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,452 Points 20k badge 2x thumb
Possibly related: if you are using internet anonymizing software (e.g. TOR), you'll need to set an exception (e.g. do not anonymize) in order to login, but it's for two sites: a) egopowerplus.com, and b) getsatisfaction.com, which appears to be the back-end server for the forums.  Before adding b) to my list, everytime I logged in, it would say I'm logged in, but when I reloaded the page, I was in fact not logged in.

The other issue I have, but this is with the main egopowerplus page is that when I view a product, and then try and click on the links to the other tabs:
The website doesn't do anything (navigation failed).  This happens with Firefox; however, with Internet Explorer and Chrome, they are both okay.

This conversation is no longer open for comments or replies.