EGO trimmer starts up for 2 seconds and then stops.

  • 2
  • Problem
  • Updated 2 years ago
  • Solved
My EGO trimmer won't run longer than 2 seconds before it shuts down. It seems like it will rev up to almost its max power then shuts down. I know it's not the battery. Any help would be greatly appreciated.
Photo of Brandon

Brandon

  • 110 Points 100 badge 2x thumb

Posted 3 years ago

  • 2
Photo of David Phillips

David Phillips

  • 1,748 Points 1k badge 2x thumb
Sounds like the ESC to me but I would call EGO
Photo of Blue Angel

Blue Angel, Champion

  • 178,394 Points 100k badge 2x thumb
Brandon, will it stay running if you don't ask for full speed?
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 80,888 Points 50k badge 2x thumb
Official Response
Brandon, which trimmer do you have? Do you have the guard installed? If it's not installed, the rev up and down is normal operation to protect the motor from overheating. We do suggest you have the guard on to make sure the line doesn't get too long which will put extra strain on the motor. We can also troubleshoot with you over the phone by calling us at 1-855-346-5656.
Photo of Brandon

Brandon

  • 110 Points 100 badge 2x thumb
Yes, the guard is not installed. I wI'll look into this. Thanks for the help.
Photo of Jacob

Jacob

  • 64,144 Points 50k badge 2x thumb
What a smart tool. Lol
Photo of Blue Angel

Blue Angel, Champion

  • 178,374 Points 100k badge 2x thumb
Jennifer nails it. Again. I forgot all about the guard missing thing... :-)
Photo of Joe Hannan

Joe Hannan

  • 60 Points
Mine does it too. When I spin the trimmer by hand there is a major drag. I removed any vegetation by unbolting the feedline assembly. The problem seems , on my trimmer, to be in the motor windings. It will spin up but not for long.
Photo of Blue Angel

Blue Angel, Champion

  • 178,374 Points 100k badge 2x thumb
Joe, sounds like a call to Customer Service is in order!