EGO stopped cutting?

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: out of date

EGO stopped cutting? It started out fine and then stopped cutting suddenly. both blades are moving in the same direction so adjusting the blades does nothing. Looks like the problem is inside the main body. Does anyone repair them? or have a suggestion?
Photo of robert

robert

  • 100 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Blue Angel

Blue Angel, Champion

  • 180,008 Points 100k badge 2x thumb
Official Response
Robert, if both blades on your hedge trimmer are moving in the same direction, you're probably right... something internal may have failed.

If you purchased from an authorized retailer you're covered under Ego's 5 year tool warranty. As Ken said, give Customer Service a call at 1-855-EGO-5656 (1-855-346-5656) 8:30-8:00 M-F 10:00-6:00 S/S.

If they're not available by phone send them an email at:

support@egopowerplus.com

Include your contact information, a description of the issue you're having, and make sure your tools and accessories are all registered:

http://egopowerplus.com/pages/registe...

Someone from the Customer Service team will get back to you ASAP, help troubleshoot your problem and get you the help you need.

Here's Ego's warranty policy as well as a list of authorized retailers:

http://egopowerplus.com/pages/warrant...