dead battery

  • 1
  • Problem
  • Updated 3 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: duplicate

The battery ran out of power before I was able to finish mowing my lawn. I put the battery in the charger for about 1 hour, and all of the lights were lit, so I tried again and the mower only stayed on for about three seconds before the mower shut off. 
Photo of Dave Ostrowski

Dave Ostrowski

  • 174 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Blue Angel

Blue Angel, Champion

  • 179,708 Points 100k badge 2x thumb
Have you tried it again since? If it refuses to power the mower after a second charging attempt, give Ego Customer Service a call and they'll get you the help you need.
Photo of Dave Ostrowski

Dave Ostrowski

  • 174 Points 100 badge 2x thumb
The battery charger shows that the battery is completely charged. I can self propel the mower, and the headlight turns on. The mower does not power up.
Photo of Dave Ostrowski

Dave Ostrowski

  • 174 Points 100 badge 2x thumb
Problem solved - one of the clips that keeps the handle extended came undone, and that prevents the mower from powering up. That is something I was unaware of.
Photo of Blue Angel

Blue Angel, Champion

  • 179,708 Points 100k badge 2x thumb
Nice! Glad you figured it out!
Photo of Exrace

Exrace

  • 8,586 Points 5k badge 2x thumb
Interesting the self propel is not included in the safety switches for the handle.
Photo of szwoopp

szwoopp, Champion

  • 104,030 Points 100k badge 2x thumb
Just about to suggest you check that

This conversation is no longer open for comments or replies.