charger red and green led lights flashing

  • 1
  • Question
  • Updated 3 months ago
  • Answered
Just unpacked my new 15" string trimmer with the standard charger and 2.5AH battery. Read the battery and charger manuals. Plugged in the charger and attached battery in order to obtain the first full charge prior to first use. Both the red and green leds on the charger flash at the same time. The manual tells us what a red flashing led means and it tells us what a green flashing led means, but it does not tell us what it means when BOTH the red and green leds are flashing at the same time. Anyone have any idea or am I just missing something very easy?
Thanks for any help.
Photo of Tarheel

Tarheel

  • 180 Points 100 badge 2x thumb

Posted 3 months ago

  • 1
Photo of William E Hanson

William E Hanson

  • 6,074 Points 5k badge 2x thumb


The owners manual did not list a symptom for both red and green LED flashing on the charger. The flashing red indicates a bad battery. Did you notice if the button light on the battery was flashing 3 colors in sequence? That indicates charging status until fully charged. The battery is warranted 3 years; take it back to Home Depot along with the charger. They're really good to take care of customers.
Photo of Oregon Mike

Oregon Mike, Champion

  • 45,336 Points 20k badge 2x thumb
Since you are well within HD's 90 day return policy just take the entire kit back and exchange for another one. Both lights flashing isn't normal that's for sure.
There's a "chance" HD would just swap battery and charger with ones from another package but best to check first if they will do that.
(Edited)
Photo of szwoopp

szwoopp, Champion

  • 80,604 Points 50k badge 2x thumb
Well it may just be a matter of terms here and there is no problem. 

If the red and green are flashing "alternately" as stated in the manual,  instead of "at the same time" as described by Tarheel, then the battery is charging normally.  We have had many posts by people being concerned about the red blinking during a normal charge cycle.

Otherwise the first 2 replies are on target.
(Edited)
Photo of Oregon Mike

Oregon Mike, Champion

  • 45,336 Points 20k badge 2x thumb
I'm not so sure that's normal. I just went and put a battery on a standard charger and only the green light is flashing on the charger. 
Photo of szwoopp

szwoopp, Champion

  • 80,604 Points 50k badge 2x thumb
Charger - agree that's a problem
Battery - normal charging is alternating red amber green

Just hoping to clarify for Tarheel.  And your comment certainly helped with that.
Photo of Oregon Mike

Oregon Mike, Champion

  • 45,336 Points 20k badge 2x thumb
I was going by his comment in his OP (bold mine) - "Both the red and green leds on the charger flash at the same time."
Photo of szwoopp

szwoopp, Champion

  • 80,604 Points 50k badge 2x thumb
yup - no argument with your original post or anything since.  I was just going for a double check before returning the product as defective. 
Photo of Tarheel

Tarheel

  • 180 Points 100 badge 2x thumb
First of all thanks for all the helpful ideas. Second, I am impressed with the following that EGO has on this forum. I have only owed a EGO tool for 24 hours, posted to this forum about 20 hours ago and have already received so many replies. 

I took the kit back to Home Depot. No questions asked. Just got another kit off the shelf. The new charger and battery leds worked as the manual described as they should. Put a full charge on the tool and all is well now.

Thanks again to all.
Photo of szwoopp

szwoopp, Champion

  • 75,244 Points 50k badge 2x thumb
Enjoy your new string trimmer - glad you got yourself a new one.