Charger isn't working

  • 2
  • Problem
  • Updated 2 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I just used my previously-charged battery to edge and trim my yard. I went to recharge the battery but the charger isn't functioning - no lights, no fans. I tried several different outlets to confirm that the trouble isn't with the outlet. In the past the charger has immediately begun to work (i.e., LED and fan power on) but there is no indication now. Please advise if there is any further troubleshooting that I can do, or if you can send a replacement.
Photo of richtcs

richtcs

  • 206 Points 100 badge 2x thumb
  • Unhappy

Posted 3 months ago

  • 2
Photo of szwoopp

szwoopp, Champion

  • 67,054 Points 50k badge 2x thumb
Official Response
The battery will not charge if it is not depleted enough, but that does not sound like it should be the case and the charge usually makes some start up noises to before it determines the battery does not need a charge.

I would run the battery some more - use a blower if you have it as they seem to eat up battery fastest.  Then put the battery on the charger - Then plug the charger in (this is a reset sequence)
If still no charger activity I would say a call to customer service is in order.

Call them first thin tomorrow - Sunday as they are closed on Monday.
1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).