Chainsaw runs for a few seconds, then stops

  • 1
  • Problem
  • Updated 2 months ago
  • In Progress
I attempted to use my EGO CS1600 (16") chainsaw today and was surprised when it shut down after only running about 3 seconds. I checked the battery, which showed fully charged. I tried again. Each time the saw ran for 1 to 5 seconds. I topped off the bar oil, removed the chain and bar and cleaned everything. No change. I tried running the saw with no bar/chain. The sprocket turned for a few seconds and shut down. The battery light remains solid green and turns off a couple seconds after the saw stops.

I assumed the battery might be bad so I swap tested it with several of my father-in-law's batteries. It behaves the same no matter which battery I use.

The issue seems to be with the chainsaw itself. Any suggestions?

The tool was produced in 03/2018.
Photo of John M.

John M.

  • 70 Points

Posted 2 months ago

  • 1
Photo of James Brady

James Brady

  • 270 Points 250 badge 2x thumb
John,  You have clearly documented your troubleshooting and I have no suggestions that you might do without opening up this unit.  I assume this is a new unit. Inform EGO and seek to return to the seller.

Thank you for updating  with unit purchase date,  Check your warranty with EGO before you continue with your troubleshooting. 
(Edited)
Photo of Jim

Jim

  • 60 Points
This same thing happened to mine, so they had me take it to home depot to get repaired under warranty. Home Depot took over a month to replace the mainboard. Last weekend the same thing happened again, so they are just sending me a new chainsaw this time. Hopefully it fixes the issue permanently.
(Edited)
Photo of csimone1986 .

csimone1986 .

  • 130 Points 100 badge 2x thumb
When runs 3 sec and it stops is because the chainsaw doesn't "read" the pin "D" of battery. Maybe could be a fail into wirings or main board inside chainsaw. That's why they tried to replace mainboard, but maybe they didn't check wires inside or loose connctions.
Better they replaced with a new .