Trying to register my product

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Trying to register my new ego power string trimmer model number ST1500SF. Nowhere on their registration page does this model number show. I tried several times to call while sitting on hold for at least 25 minutes both times before I hung up. I did choose the option for a callback. Never received that call yet. Attempted again for the third time and also filed online issue submission. Hoping to get a response from that. Basically, I don't have the time to spend just to register my product. 
Photo of Andreas Gieryic

Andreas Gieryic

  • 90 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Amber F.

Amber F.

  • 68,360 Points 50k badge 2x thumb
Official Response
Sorry to hear that, Andreas! When registering online, make sure you check "Power+ 15" String Trimmer with Rapid Reload Head"  and select the "tool" rather than "kit" option after that. Including screenshots below for reference. We hope this helps!