Bought a EGO backpack blower. Had it for one month and worked perfectly. But now I went to use it and it fired up for about 3 Thanks Craig

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

Bought a EGO backpack blower. Had it for one month and worked perfectly. But now I went to use it and it fired up for about 30 seconds and it quit. Any help would be appreciated here. Battery shows fully charged. Thanks Craig
Photo of Craig Newman

Craig Newman

  • 170 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Blue Angel

Blue Angel, Champion

  • 178,712 Points 100k badge 2x thumb
Official Response
Off to a bad start!

Do you have any other Ego tools/batteries? If so you can switch them around to determine if it's the tool or the battery acting up. If not, placing the battery on the charger may tell you if it's at fault.

Either way, a call to Ego Customer Service is in order. If you can't pinpoint the offender yourself they can help you figure it out and get you back in business.
Photo of Craig Newman

Craig Newman

  • 170 Points 100 badge 2x thumb
Thanks for the help. No I don't have any other products. I really like this blower and I did get with the company and they're sending me now new pieces parts. I believe the battery is good I believe the charger is good. Something seems to be shutting the blower off. All the lights on the battery and charger seem to be operating normally to me. Thanks again. Very respectively Craig
Photo of David Cline

David Cline

  • 36,932 Points 20k badge 2x thumb
What does the light on the battery do when it shuts off? What happens when you place it on the charger? Does the blower run longer on low than on high/turbo before shutting off?

You say you've had it a month—is this by any chance the first time you're using since just after you bought it? If the battery is unused for 30 days it will self-discharge down to 30% (even sitting on the charger) to prolong battery life during storage. If so, it should charge back to 100% now if placed back on the charger.
Photo of TheAtomTwister

TheAtomTwister

  • 13,058 Points 10k badge 2x thumb
It sounds like you have a circuit failure. The battery seems to be working... When you pull the trigger, does it do anything? Does the battery light pop on when you pull the trigger? If not, then there is a problem probably with the circuits in the blower. Do what Blue Angel suggests, call 1-855-346-5656, or e-mail EGO at support.egopowerplus.com. I do not know how many calls they get now of days, but calling is usually the quickest way to get response.
Photo of Craig Newman

Craig Newman

  • 170 Points 100 badge 2x thumb
Thank you for your reply. To answer your question when I pull the trigger it does start to work for the first 10 seconds and then stops the light on the battery is on and green. I've looked the unit over very well doesn't seem to be any damage of any sort overheating of the battery or anything like that. Kind of at a loss. I think I'll do what you suggested and call the one 800. Thanks again Craig

This conversation is no longer open for comments or replies.