Blower battery charger question

  • 2
  • Question
  • Updated 1 year ago
  • Answered
Just bought the power plus leaf blower and love it. However, went to recharge the battery today and found an issue I can't seem to resolve. As soon as I plugged the charger into wall, both red and green led's started flashing. Put the battery on charger and battery light didn't come on at all. I'm assuming something is malfunctioning with charger itself, but not sure. Anyone come across this situation?
Photo of schunkb

schunkb

  • 100 Points 100 badge 2x thumb

Posted 1 year ago

  • 2
Photo of Jacob

Jacob, Champion

  • 58,464 Points 50k badge 2x thumb
Havent seen this before. I have heard clicking from a relay inside.

Both lights i am assuming is a bad thing
Photo of Egocentric

Egocentric

  • 6,208 Points 5k badge 2x thumb
Not very likely, but it is a polarized plug.  Make sure you don't have it in wrong.  If you have an old style non-polarized receptacle, try flipping the plug and see if straightens out.  
(Edited)
Photo of Jacob

Jacob, Champion

  • 58,424 Points 50k badge 2x thumb
Good point, and try a different outlet
Photo of schunkb

schunkb

  • 100 Points 100 badge 2x thumb
Called into customer service. Rep hadn't heard of it either; have a new charging base on its way. Couldn't have been happier with the customer service and quick resolution!
Photo of Egocentric

Egocentric

  • 6,208 Points 5k badge 2x thumb
Glad you had a good experience with customer service.  Hope your new charger fixes the problem.  

This conversation is no longer open for comments or replies.