BLINKING GREEN LIGHT BATTERY - replacement failed with exact same symptoms

  • 2
  • Problem
  • Updated 11 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

Is anyone else extremely concerned with the reliability of these batteries?  I purchased a blower kit, trimmer kit, and mower kit back in June.  Within two weeks the battery on the trimmer kit started failing with the blinking green light.  Ego sent out a replacement which started showing the EXACT same issues yesterday (Sept 2nd).  One bad battery I can understand - it's technology and nothing is perfect.  But to have TWO batteries fail in the same fashion in a few months makes me really nervous there's no reliability in these things.  Yes it's covered under warranty - but I didn't buy this to play a never ending game of calling customer service, sitting on hold, troubleshooting the battery, waiting for a replacement, ...  I see on the forums I'm not the only one with these issues either.  Makes me very concerned I made the wrong choice in buying Ego products.
Photo of lrbw1 .

lrbw1 .

  • 80 Points 75 badge 2x thumb
  • Worried

Posted 1 year ago

  • 2
Photo of Blue Angel

Blue Angel, Champion

  • 158,438 Points 100k badge 2x thumb
Statistically speaking, I'd say you are highly unlikely to see two batteries with this issue end up in the hands of the same owner... I think I've seen this reported once before.
Photo of Dwayne Williams

Dwayne Williams

  • 110 Points 100 badge 2x thumb
Statistically speaking, you should NEVER see this happening.  A company that cares about it's customers and it's reputation should take better care to ensure they are sending out something that is tested and reliable in a warranty replacement situation.  If there's a chance the 2.5 Ah battery has an issue you shouldn't send it out to replace one that's failed.    
Photo of Blue Angel

Blue Angel, Champion

  • 158,438 Points 100k badge 2x thumb
1. Statistically speaking, that's impossible.  :-)

2. So Ego should not replace any defective 2.5Ah batteries then?  ;-)
Photo of Amber F.

Amber F., Official EGO Rep

  • 65,282 Points 50k badge 2x thumb
Official Response
We totally understand your concern, as what you've described is highly unusual. Please give us a call and we'll do our best to make this right as quickly as possible (1-855-346-5656). If you encounter any wait time, just leave a voicemail and we'll contact you directly. 
Photo of Gerry Lum

Gerry Lum

  • 114 Points 100 badge 2x thumb
Yes, I am having the same problem with the blinking light.  The 15" trimmer was purchased in March 2017, with all three (3) items being registered - trimmer, battery, and charger.  After usage, noticed the flashing green light, charged and flashing continued. Read forums and initiated a case on Sunday, September 3rd but, I have yet to hear a response back.
Photo of Amber F.

Amber F., Official EGO Rep

  • 65,282 Points 50k badge 2x thumb
Sorry to hear about your battery, Gerry, but we're happy to help. Opening a case online can take longer to process. For the speediest resolution, we strongly encourage calling first (leave a voicemail if there is any extended wait). The team is working through cases right now and should be in touch with you shortly. 
Photo of Ken

Ken, Champion

  • 48,942 Points 20k badge 2x thumb
Two in a row makes me wonder whether the charger is the culprit.
Photo of Michael G

Michael G

  • 6,420 Points 5k badge 2x thumb
Or the trimmer. I too had my string trimmer ST1502SF battery go into "green-blinking-of-death" and had a date code of March 2017. I saw somewhere that EGO said it was a bad batch of batteries but that doesn't make sense since the OP'er had a replacement fail too. I seem to also recall this failure mode mostly on string trimmers too.
Photo of Doug Halliday

Doug Halliday

  • 100 Points 100 badge 2x thumb
Exactly the same situation here.  Trimmer was purchased in May 2017.  Battery will no longer charge.  Flashing green led issue from day 1.
Photo of Jeff Delabre

Jeff Delabre

  • 60 Points
Mine is doing it also. My EGO Trimmer- 56v worked great for 1 month.. Now the battery keeps blinking until it dies. Everytime I use it now I have to charge it 50 minutes. And this will cause the battery to wear out Very Fast !!!  Love the Power.. Very unhappy about the battery. Plus I Replaced the garbage head.. 
Photo of Amber F.

Amber F., Official EGO Rep

  • 65,078 Points 50k badge 2x thumb
Please call our service team at 1-855-346-5656 as soon as you can, Jeff. They're happy to help. Also, if you encounter any wait time, just leave a voicemail and we'll call you back directly. 
Photo of Doug Halliday

Doug Halliday

  • 100 Points 100 badge 2x thumb
I have discovered that EGO does not return service calls within 24 hours, which is their claim.  I returned the trimmer and purchased a competitive product.  
Photo of szwoopp

szwoopp, Champion

  • 59,446 Points 50k badge 2x thumb
Can't argue with reasoning like that.
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,280 Points 20k badge 2x thumb
Doug, curious what competitive product you chose?
Photo of Doug Halliday

Doug Halliday

  • 100 Points 100 badge 2x thumb
I don't think it would be fair to get into that here.  The competitive product is less high-end and somewhat less expensive, but ratings and reviews are positive.  
Photo of Dwayne Williams

Dwayne Williams

  • 110 Points 100 badge 2x thumb
I'm writing this while on forever hold waiting for customer service.  I had a very similar experience.  Battery died with the blinking green light issue.  Got a replacement and the replacement is doing the exact same thing after a few weeks.  I have the "regular" charger that comes with the trimmer kit and the express charger that comes with the mower.  Doesn't seem to matter which charger I use so in my case I don't think it's a charger thing.  The 5.0 Ah battery that came with the mower seems fine so maybe there's just something wrong with a whole batch of the 2.5 Ah batteries.    

EDIT:  Was on hold so long I finally got the "leave us a voicemail and we will call you back within 24 hours".  Left my message and will see if I get the call.
(Edited)
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,280 Points 20k badge 2x thumb
For the double failure case; are the serial numbers very close together?  While a very low probability, if you received two, then that could be indicative of a bad batch problem.  Or are the manufacture date ranges close (e.g. March 2017)?
Photo of Greg Reinhard

Greg Reinhard

  • 80 Points 75 badge 2x thumb
I've used my 15" trimmer twice and now I am having the same problem, he mysterious blinking green light.  I was hoping this was normal but couldn't find anything in the manual and I know enough that a continuous blinking light will drain the battery over time.  I guess I need to contact CS. From what I am reading I may not get through
Photo of Oregon Mike

Oregon Mike, Champion

  • 29,786 Points 20k badge 2x thumb
Call early in the day. That seems to be the most successful method for getting through to CS.
Photo of Amber F.

Amber F., Official EGO Rep

  • 65,282 Points 50k badge 2x thumb
You can also leave a voicemail or request a call back. 

This conversation is no longer open for comments or replies.