Battery won't charge, shows 100% even after 30 minutes of activity

  • 3
  • Problem
  • Updated 3 years ago
  • In Progress
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: my battery won't charge

The battery for my EGO 21in mower will not charge on the charger even after extended use.  When placing the battery in the charger, the battery light blinks yellow, green, and then after a short pause blinks red once while the charger lights show four green.  Once in about 20-30 tries, it will actually charge, and not sure why.  Now it seems to not charge at all anymore.  

I registered a support case a week ago but have heard nothing back from the manufacturer.  I'm torn - on one hand, I really like the performance of the mower, but the battery issue and lack of customer support response has me considering taking it back to the store (still inside the return window) and going back to a gas model, sadly.  

Has anyone had this issue (I've seen similar, but not quite the same) and found a workaround until the battery and charge can be replaced?   
Photo of Erik

Erik

  • 102 Points 100 badge 2x thumb
  • frustrated

Posted 3 years ago

  • 3
Photo of Blue Angel

Blue Angel, Champion

  • 179,708 Points 100k badge 2x thumb
Official Response
Erik, sounds like you need a new battery! Try calling Customer Service, they get overwhelmed with activity this time of year and it takes them a while to respond to emails. Once you reach them they'll have you back in business shortly!
Photo of Amber F.

Amber F., Official EGO Rep

  • 68,208 Points 50k badge 2x thumb
Official Response
Sounds like something is wrong with your battery, Eric. Our apologies for the inconvenience and frustration- it’s totally understandable. Just don’t forget that we’re here to help. Give us a call at 1-855-346-5656