BATTERY WONT CHARGE, FLASHING RED

  • 6
  • Problem
  • Updated 3 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: duplicate

I have been loving my mower.

 Today I removed my battery from the charger after being on overnight, and put into the mower.  Within 10 seconds it was blinking red and died. I tried charging it again several times but it blinks green for a few minutes then shuts off and stays red.

Photo of Fred

Fred

  • 90 Points 75 badge 2x thumb

Posted 4 years ago

  • 6
Photo of Enthuz

Enthuz

  • 164 Points 100 badge 2x thumb
I say call Ego support. There's countless testimonies here of how much Ego stands behinds their batteries.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,028 Points 50k badge 2x thumb
Official Response
Fred, we're sorry to hear about your battery.  Our customer service team would like to do a little troubleshooting with you.  Please give us a call at 1-855-346-5656 so we can help you.  We're available 7 days a week.
Photo of Talicia Minor

Talicia Minor

  • 376 Points 250 badge 2x thumb
I'm having the same issue
Photo of John

John

  • 862 Points 500 badge 2x thumb

Today I purchased a second 2 ah battery, brought it home and put in on the charger. I mowed until the other battery in the mower went red. The new one had charged, so switched them out. The light for the new battery came on red and stayed red until I finished the front yard, about 4200 sq. ft. The battery light never did show green on the mower. When I put it on the charger after I was done, it showed 25% charge left and it charged to all 4 lights were green. Will be anxious to see if the battery light stays red the next time it is in the mower.


Photo of Blue Angel

Blue Angel, Champion

  • 179,788 Points 100k badge 2x thumb
John, let us know how the next use goes. If the light still remains red during use you will need to have it exchanged for a new one.
Photo of John

John

  • 862 Points 500 badge 2x thumb

I haven't mowed with the new battery since I last wrote, but I did take it off the charger after it had been on overnight and put it in the mower and the light did come on green, so maybe it was just a hiccup. I will get back after I use it to mow again to let you know how it works. I do know that with the slightly over 4200 sq. ft. in the front, one 2.0AH battery will not finish the yard. Maybe after a few charges are put on the battery it will.


(Edited)
Photo of Blue Angel

Blue Angel, Champion

  • 179,788 Points 100k badge 2x thumb
Thanks for the update, John. Hopefully it's smooth sailing from here on out.

As far as cutting 4200 sqft with just the 2Ah battery, I don't know about that. My whole lot is not that big, and there's a house on it, and I can just get through my lawn with a 2Ah battery. Everyone's grass is different, and that's on a fairly low setting (3) on the 20" mower, so as usual, YMMV. :-)
Photo of John

John

  • 862 Points 500 badge 2x thumb
I have mowed several times now and have used the second battery that showed red during the first use several times and it has shown green each time I've put it in the mower. Funny what happened the first time, but it seems to have corrected itself. It still takes both 2.0 ah batteries to do the front. A full charged one then part of the second. The wife  mowed the back and dropped the cutting height one notch. She was able to do the back with a partial charged battery and part of a full charge. I hope it continues to work as good. I think it would have been better though if the mower would have come with a 4.0 ah battery, as that would probably allow me to mow front and back with one battery. Thank goodness for the quick charge.
Photo of Jacob

Jacob

  • 64,900 Points 50k badge 2x thumb
Where did you find a mower that didnt come with a 4ah or 5ah or 7.5ah. I did not know they were sold with 2 ah batteries anywhere. Mine came with the 4 ah. New ones come with the 5ah and 7.5ah.
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,028 Points 50k badge 2x thumb
Hi John, we're curious too.  We never sold the mower with a 2.0Ah battery.  It's always been sold with a 4.0Ah battery or higher.
Photo of Dave .

Dave .

  • 21,706 Points 20k badge 2x thumb
Are the support lines open even on holiday weekends?
Photo of David Cline

David Cline

  • 37,182 Points 20k badge 2x thumb
I believe that Ego is closed through Memorial Day. You can leave a message for someone to return your call by mid-week, or just wait until Tuesday to call.
Photo of Ryan O'Neill

Ryan O'Neill

  • 60 Points
I am having the exact same issue. My battery is from March 2015 and now will not charge.
I am hoping they exchange this. I have two other batteries, I hope they dont also die within a year. I emailed their customer support see if they can exchange the battery.
Photo of Talicia Minor

Talicia Minor

  • 376 Points 250 badge 2x thumb
I think mine is from the same time frame. Right now I am using my two batteries that came with the blower and weed eater to mow my yard.
Photo of Jacob

Jacob

  • 64,900 Points 50k badge 2x thumb
Mine did that yesterday. I tried a different charger and it charged no problem. So it might be the charger too.
Photo of John

John

  • 862 Points 500 badge 2x thumb
Apparently the charger is working OK as the original battery charged and showed the green light. The new battery seemed to take a charge both times, but the light showed a steady red instead of green. Will see what happens the next time I put it in the mower.
Photo of Jacob

Jacob

  • 64,900 Points 50k badge 2x thumb
Well steady red means the battery is too hot. When it cools down it will charge. If however, the battery is defective, you can warranty it, or return it to home depot. If the battery's internal thermal sensor is bad, it could be telling the charger that its too warm when it actually isn't. I have charged A LOT of batteries, i rarely see the red light steady on, but i do see it for the 2 AH battery from time to time.
Photo of Stan

Stan

  • 120 Points 100 badge 2x thumb
Super impressed with the EGO customer service received today on this issue.  I was able to register my product(s) over the phone, and it was quickly determined that a replacement battery was needed to address this issue.  Whole process took about 5 minutes from the time I dialled.  I will have concerns if the replacement isn't received, but so far so good.  Thanks.
Photo of David HD

David HD, Champion

  • 34,958 Points 20k badge 2x thumb
Glad to hear it Stan and thanks for sharing your experience with CS!

This conversation is no longer open for comments or replies.