Battery stays on (green light illuminated) with mower off

  • 1
  • Problem
  • Updated 3 months ago
  • Solved
  • (Edited)
Ego 21" self-propelled mower. My lot is small - I normally get 2+ cuts out of a full charge. BUT - battery was dead this weekend after one cut a week ago with a just-charged battery. Cut grass with second battery but when I collapsed the handle to put mower away, green light on battery remained illuminated/"on-line", which, it seems logical, is what killed battery #1 while the mower sat idle for the week in between cuts. Any ideas from the community? Thank you.
Photo of Rob Loewy

Rob Loewy

  • 80 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Ken

Ken, Champion

  • 73,580 Points 50k badge 2x thumb
The best thing to do is take the battery out of the mower when it isn't being used.
Photo of szwoopp

szwoopp, Champion

  • 105,650 Points 100k badge 2x thumb
Never had a problem , but that is certainly a simple fix. 
Photo of Rob Loewy

Rob Loewy

  • 80 Points 75 badge 2x thumb
That's what I'm doing already as a work-around but hoped someone had solved.
Photo of Ken

Ken, Champion

  • 73,580 Points 50k badge 2x thumb
The owners manual does recommend removing the battery when the mower isn't in use.
Photo of Bill White

Bill White

  • 60 Points
My green light stays on as well, I have been removing it when not in use, not sure of any other fix???
Photo of Ken

Ken, Champion

  • 73,580 Points 50k badge 2x thumb
As I wrote above, you shouldn't store t by e battery in the mower when not in use.
Photo of Mike Sergent

Mike Sergent

  • 60 Points
I have the same issue, I remove the battery when not in use. I know that doesn't help with why it does that. My guess is moisture got into the electronics causing a malfunction. I will be sending my mower in for repair's as I am also having issue with the variable speed not working.
Photo of Dave .

Dave .

  • 21,706 Points 20k badge 2x thumb
My original mower which was sent to Home Depot Repair Hell came back with a problem it never had in 3 years--the battery light stayed on.  For that and issues with the self-propulsion, EGO replaced it with a new mower.  Kudos for EGO for honoring the warranty, and thumbs-down to Home Depot for their ineptitude.
Photo of Paul Christenson

Paul Christenson

  • 7,586 Points 5k badge 2x thumb
Photo of Mike Arch

Mike Arch

  • 60 Points
I have a weed whacker and had this issue. I use it along with a gas one as a landscaper. I had the whipper on the rack and the gas one was holding down the safety of the Ego. When I got it off the safety no issues. Maybe there is an issue with the mowers safety switch.