Battery says fully charged when it's depleted

  • 1
  • Question
  • Updated 5 months ago
  • In Progress
I just got a mower/blower/trimmer two weeks ago. After the first use, everything worked great. When the battery died, I replaced it with the smaller battery to finish the job, but I noticed when putting the dead battery on the charger, it gave the indication it was fully charged. After finishing the yard, I swapped the batteries on the charger and the other battery had the indication that it was fully charged as well. I kept the larger battery on the charger for a few hours and tried to run the trimmer, but it didn't work with either battery. But again, when put on the charger, both are supposedly fully charged according to the charger. Am I doing something wrong or is my charger defective?
Photo of Marc Sams

Marc Sams

  • 70 Points

Posted 5 months ago

  • 1
Photo of Oregon Mike

Oregon Mike, Champion

  • 33,026 Points 20k badge 2x thumb
Official Response
Sure sounds like the charger. Try removing the battery from the charger and then unplug the charger for a good 30 seconds to a minute. Then plug the charger in and reinstall the battery to see if that helps.
Another thought is if you might have overdepleted the battery pack(s) although it seems unlikely you'd do the same to both. 
If the troubleshooting step doesn't work, you'll likely need to call CS. Best to call early in the day to avoid hold times. Note they are closed this Monday for Memorial Day.
They can be reached at 1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).