Battery runs hot

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
Battery runs Hot. I have a Ego mower, bought an extra 5.0 battery and the Ego backpack blower. One of the5.0 batteries runs hot every time I use it. So when it dies and I plug it into the charger it shows it is hot and has to cool off for about 10 minutes before it will start charging. The other 2 batteries I have do not do this. This is very frustrating because I am usually waiting for this battery to charge so I can finish my yard work. I have 2 chargers - 30 minute that came with the mower and 50 minutes that came with blower. This battery will show hot no matter what charger I try to use.
Photo of Kevin Cooksey

Kevin Cooksey

  • 70 Points
  • frustrated

Posted 2 years ago

  • 1
Photo of Blue Angel

Blue Angel, Champion

  • 180,008 Points 100k badge 2x thumb
Official Response
Does it feel any hotter than the other batteries after use? If not, it could have a defective thermistor indicating it's hotter than actual.

If it is actually hotter than the others I'm not sure what the issue could be.

Either way, give Ego Customer Service a call and they'll get you fixed up.
Photo of Jacob

Jacob

  • 65,000 Points 50k badge 2x thumb
If you can feel the heat, stop using it. This is weird and I would like to know what is figured out, so please report back what you find out..
Photo of Burugee

Burugee

  • 264 Points 250 badge 2x thumb
Just to confirm. You are saying all Batteries are same 5Ah Batteries right. And one gets hot during use, other do not get hot? If that is the case, probably return and get a new one or call CS.
Photo of John Noonan

John Noonan

  • 60 Points
Only the battery for my mower 5Ah.
Photo of Blue Angel

Blue Angel, Champion

  • 180,008 Points 100k badge 2x thumb
John, do you have the same issue where the battery needs a cooling off period on the charger before charging will begin?

For the record, it's quite normal for the end cap of the mower battery to be hot after mowing; it's sitting in the sun under a clear plastic cover with no air circulation. Putting your hand in the middle of the battery where the cells are shows the battery isn't really hot at all.
Photo of Oregon Mike

Oregon Mike, Champion

  • 72,352 Points 50k badge 2x thumb
Ok, just to clarify? You have 2 5 ah batteries. One gets hot, one does not? That *might* be normal because that is mentioned in the battery charger manual about waiting for a battery to cool before charging will start. After the battery has cooled and has charged does it work as normal?
Probably the best thing to do is to have your other 5 ah battery charged and ready to swap in to the mower when the first one runs down. That way you don't have to wait for a battery to cool and charge.

"CHARGING A HOT OR COLD BATTERY PACK If the battery pack is out of the normal temperature range, LED1 will shine red. When the battery pack cools down to approximately 135°F (57°C) or warms to more than 37°F (3°C), the charger will automatically begin charging and the 4 LEDs will sequence normally."