Battery not charging

  • 7
  • Question
  • Updated 2 days ago
  • Answered
When I place my discharged 56v battery (red indicator) on my charger, the charging light briefly shows on green bar then all 4 green lights come on. The battery is still dead and the charger does not initiate a charging cycle. What’s up?
Photo of John Vaille

John Vaille

  • 160 Points 100 badge 2x thumb
  • concerned

Posted 2 years ago

  • 7
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
Sounds like you are trying it on the rapid charger. Do you also have a standard charger? If so, give it a try on there to see if it's the battery or charger. Alternately, if you have another battery that you know will charge on the rapid charger put it on the rapid charger to make sure the charger is working ok.
Photo of craig koralek

craig koralek

  • 162 Points 100 badge 2x thumb
I took the battery and banged it on the concrete garage floor.  I then put it back in the mower and, presto, it worked!
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
Probably not a good system.  A call to customer service would be much more helpful in the long run.
Photo of craig koralek

craig koralek

  • 162 Points 100 badge 2x thumb
Actually, my battery was out of warranty by a month. I called EGO and they said “tough luck.” I checked and a new battery was nearly $200. Spending that much every 3 years is absurd. I only use the mower 5
months a year. I looked online and someone suggested giving the battery a hard tap. It worked and had been recharged several times since. It is with a try!!!!
Photo of Chris Coppola

Chris Coppola

  • 80 Points 75 badge 2x thumb
Just read this. Same here. I'm lazy, so I assessed the flattest/most durable surface of the battery, held it approx. 6 inches off my concrete garage floor, and whacked it. One solid hit but not like a neanderthal. Put it on the charger and the fan fired up, all lights in order. Thank you, internet!
(Edited)
I just read all the messages and responses here, and spent half an hour on the phone with customer support. Nothing they suggested worked. As a last resort, and kind of as a joke, I held it a couple inches off the floor and dropped it, and now it’s charging like normal. Go figure.
Photo of Renee Hughes

Renee Hughes

  • 112 Points 100 badge 2x thumb
OMG!!!! Chris Coppola, I have been having major problems out of my battery as well, My charger was free, it came with my lawn mower, so why would I tear it up, but I took your advice because I was tired of it acting up, so I held it 6 inches off of my carpet and dropped it and guess what it is charging... Thank you soooooo much because I got my EGO Lawn Mower with all the accessories for $300.00 dollars in 2015 that is when they were experimenting with the idea of a battery charge lawn mower and I priced one today and I was like I can't afford it, so I said it couldn't hurt to try it and I am soooo happy I did.. again thank you...
(Edited)
Photo of Don Myers

Don Myers

  • 110 Points 100 badge 2x thumb
I'm glad I found this.  One of my 2.0 AH batteries quit last week.  If I put it on the charger, the fan would kick on, it would flash green a few times, then go to solid red to indicate a bad battery. I just tried banging it on the garage floor, and putting it on the charger. It worked!  It's now charged and ready to use. Thanks!
Photo of Renee Hughes

Renee Hughes

  • 112 Points 100 badge 2x thumb
Don Myers, When I purchased my Ego Lawnmower 4 yrs ago for $300, with all of the accessories included..I priced some batteries and they were way over my budget, so throwing the battery around is a lot cheaper than purchasing one, because my warranty expired last year.. Happy cutting...
(Edited)
Photo of olsenps

olsenps

  • 80 Points 75 badge 2x thumb
Worked for me too.  Battery was seemingly dead, wouldn't charge, and plugging in the charger after the battery was in place didn't work.  Dropping the battery from about 4" off the floor got it to again start charging.
Photo of David

David

  • 150 Points 100 badge 2x thumb
did not work for me
Photo of Kevin Kane

Kevin Kane

  • 60 Points
Worked for me, I noticed after knocking it on the floor after the initial fan turning on in the charger I could hear a second fan come on thank you!
Photo of lisa

lisa

  • 100 Points 100 badge 2x thumb
Dropping battery hard several times from only about 6” onto towel on kitchen counter just worked for me. Makes sense, been banging batteries all my life. Thank you, forum, thank you. Saved some $$. Love my ego mower, been working fine for at least 5 years. Thx again.
Photo of lisa

lisa

  • 100 Points 100 badge 2x thumb
Dropping battery hard several times from only about 6” onto towel on kitchen counter just worked for me. Makes sense, been banging batteries all my life. Thank you, forum, thank you. Saved some $$. Love my ego mower, been working fine for at least 5 years. Thx again.
Photo of Atwater

Atwater

  • 60 Points
It worked for me too.  The representative at EGO has no idea why and did not recommended.  But, my 3 year warranty has passed so glad I dropped it!  
Photo of Tom Berna

Tom Berna

  • 60 Points
Did not work for me. Tried 2 batteries. One has the fan come on, the other just clicks many times. I love my EGO tools.
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
2 batteries - 1 charger - maybe the charger is your problem item
Photo of Robin Bradley

Robin Bradley

  • 60 Points
My 56v is not charging is it supposed to make a fan nose when charging
Photo of UCD BNXT

UCD BNXT

  • 60 Points
Battery less than 1 year. Not charging. Heard about drop method. I wrapped it on all sides with a rubber mallet. WORKED!!! Vids show spot welded connections so no idea wtf is going on. Contacted CS and we shall see...
Photo of John Vaille

John Vaille

  • 160 Points 100 badge 2x thumb
Oregon Mike,
I only have the one charger that came with the mower. It has worked well for 3 years, but now when I place the battery on the charger a single green light comes one for a second or so and then all four lights come on the charger indicating that the battery is charged. Before this, it the charger fan would come on and the battery charge over the next few minutes/hours. Now there is nothing happening to the battery. The indicator on the battery remains red. 
Frankly, I suspect that the charge is not working properly. When I unplug the charger a, wait a minute or so and replug it, the first green light comes on and the fan stars for about a second. When I put the battery in, the first green light lights and then all four light up. No fan, no charging cycle.
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
You could try putting the battery on the charger with the charger not plugged in.  Then with the battery in place plug the charger in.  This can reset their brains.

Worth a try.  Then call CS like David said
Photo of Ursula Libby

Ursula Libby

  • 80 Points 75 badge 2x thumb
Szwoop is “right on”.   Battery wouldn’t charge...Heading to the Big Box & decided to do. google.  Lucky for me, szwoop had the simple answer.  Restated perfectly, case closed.
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
So glad it worked Ursula !  Thanks for posting.
Photo of dmbrown

dmbrown

  • 0 Points
Didn't work for me. Thanks, anyway, though, for a few moments of hope! :D 
Photo of David HD

David HD, Champion

  • 35,308 Points 20k badge 2x thumb
John, I would contact Customer Service in the morning to have them diagnose the problem.  If the charger is defective, then they will send you a replacement charger.  This occurred to me last year as well, and EGO took care of it - so you are covered!

They can be reached at 1-855-EGO-5656 (1-855-346-5656) from 8:30AM - 8:00PM EST (Monday - Friday) & 10:00AM - 6:00PM EST (Saturday & Sunday).

Photo of Holly Redmond

Holly Redmond

  • 90 Points 75 badge 2x thumb
can't get a hold of any one ! aggerivating!

Photo of Lee Filbert

Lee Filbert

  • 150 Points 100 badge 2x thumb
Same issue with my charger and battery after 2 years. They just sent a new battery and now that will not take a charge. 3 weeks of downtime, with limited support. It took 3 calls with call backs when I was not near the device to troubleshoot.
Photo of szwoopp

szwoopp, Champion

  • 113,616 Points 100k badge 2x thumb
Are you certain the battery needs a charge,  It will not charge if close to fully charged already.

Do you have another charger to determine if the charger is the issue.
Photo of Chad Redman

Chad Redman

  • 100 Points 100 badge 2x thumb
I thought this was a joke, battery indicator red, all lights on charger green...not charging....dropped battery with light side up from about 10 inches 6 times, it’s now taking a charge...and now I wonder why this is such a common issue...why a minor jarring wakes the battery from a slumber...regardless, it worked and thank you all!!
Photo of Don Myers

Don Myers

  • 110 Points 100 badge 2x thumb
I'm guessing the pack contains 18650 battery cells, and there's some oxidation on the contact points. I remember when I was a kid, sometimes a radio wouldn't work if it sat awhile.  I could slap it and it would jar the batteries enough to have good contact.  Could be the same thing. If the cells are protected, they could be really sensitive to things like that. Just my guess.  I've never opened one up to look at the inside. Seems a lot of packs use those 18650 batteries crammed into one pack though.
Photo of Richard Buchanan

Richard Buchanan

  • 60 Points
well if that's the solution i'll try electrical contact spray rather than risk damaging battery
Photo of Lee Filbert

Lee Filbert

  • 150 Points 100 badge 2x thumb
New battery was fully discharged since I ran it down after receipt.  CS is sending out a new charger.
Photo of john pettinger

john pettinger

  • 140 Points 100 badge 2x thumb
My battery went out after 2 years and 10 months, I called the EGO customer service and even though I had not initially registered the product, he went ahead and registered the product and sent out a new battery as there is a 3 year warranty on that.
Photo of szwoopp

szwoopp, Champion

  • 113,616 Points 100k badge 2x thumb
Good to hear John.  Ego CS does a great job in my experience as well.
Photo of GP Haas

GP Haas

  • 140 Points 100 badge 2x thumb
My battery just went out after 2 years and 6 months and CS answered my call within 5 minutes and helped me register my products and sent out a new battery same day.
Photo of Oregon Mike

Oregon Mike, Champion

  • 80,800 Points 50k badge 2x thumb
GP, thanks for the great CS report. I think that's more the case than what we see on this forum.
Photo of szwoopp

szwoopp, Champion

  • 113,616 Points 100k badge 2x thumb
Yup - people seem more anxious to complain than take time for compliment.
Thanks for the report GP
Photo of Susan Taylor

Susan Taylor

  • 60 Points
Put the.battery.in.no lights come on why not on the charger for the mower
Photo of Tim R. Benson

Tim R. Benson

  • 204 Points 100 badge 2x thumb
I have two EGO 5Ah batteries. One from a mower 3 years ago and one recently this year. The mower battery looks like it charges on the charger but when I try and use it it goes red right away. Tried the temperature trick and tried to run it down did not work. What worked was dropping it about 6 ” 6 times on a hard surface lights side up. Apparently they build up with oxidation and this refreshes the contacts on the inside. I thought someone was crazy for mentioning it but it works great now.
Photo of John Reames

John Reames

  • 348 Points 250 badge 2x thumb
Really strange that dropping the battery worked... would not recommend that fix to anyone.
Photo of Kenny Mars

Kenny Mars

  • 1,224 Points 1k badge 2x thumb
Why not, if it works. If at once you don't succeed, get a bigger Hammer
Photo of Joseph Maguire

Joseph Maguire

  • 94 Points 75 badge 2x thumb
The battery pack is not just comprised of battery cells.  It also has sensors, some electronics, and cooling mechanisms.  Think of it like dropping a TV or stereo; maybe it will start working, or perhaps dropping it will completely damage it.  Skylab astronauts once "fixed" a malfunctioning battery charger on the solar panels by giving it a whack with a hammer, but they were in a position where replacement was not an option. 

Is there a better way to remove the oxidation, perhaps?
Photo of UCD BNXT

UCD BNXT

  • 60 Points
IF you watch vids on the battery pack, it appears the connections are spot welded.  Contact cleaner and other stuff shouldn't be necessary.  ALSO EGO says their batteries have drop resistance... not sure of their tests so give it a whack....
Photo of David

David

  • 150 Points 100 badge 2x thumb
This happened to my battery over a week ago and no response from EGO.  How long does one wait before going back to gas?  lawn is growing.
seems like a fast resolve kind of issue seeing that Home Depot is local everywhere. 
Photo of HMR HMR

HMR HMR

  • 100 Points 100 badge 2x thumb
banged battery on floor, several differant ways, plugged in with battery on charger. Its working!! Not sure which remedy was responsible.
Photo of paula

paula

  • 62 Points
Wow did the same and battery seems to be charging
Photo of Bruce Sharer

Bruce Sharer

  • 80 Points 75 badge 2x thumb
My battery is 3 years old and started dying w/ yellow light on mower early in mowing. Happened last 2 times.  It would work again but I knew something was amiss. This morning I started and battery immediately died. I read the comments here......dropped the battery 4 inches onto carpeted floor........and I was off to the races. Worked of rme. Thanks for the tip! I use this same battery for mower, chain saw and pruning tool. Love Ego!
(Edited)
Photo of John Reames

John Reames

  • 348 Points 250 badge 2x thumb
Again.... strange fix. Not recommended
Photo of Kenny Mars

Kenny Mars

  • 1,148 Points 1k badge 2x thumb
Evedently you don't believe in Macgyver ing
Photo of Dan Sweet

Dan Sweet

  • 82 Points 75 badge 2x thumb
MIne wouldn't charge. I tried dropping it a bunch of times but no luck. Then, I saw the suggestion to plug the charger in after inserting the battery. Worked like a charm!
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
Good to hear you are back in business Dan
The plugging in the charger with the battery installed is a reset function built into the battery and charger. 
The battery dropping is not a prescribed repair method
Photo of Barbara Klauke

Barbara Klauke

  • 120 Points 100 badge 2x thumb
I have to say thank you for all your advise on dead batteries...i am new to EGO - just bught my first selfpropelled mower and love it. My christmas present
Photo of Stephen Atlanta

Stephen Atlanta

  • 80 Points 75 badge 2x thumb
Improbable though it seemed I tried dropping it and it is working.  Who would have believed it (except somebody unwilling to shell out $200 for a new battery:) )
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
Thanks for letting us know Stephen.
Photo of John Reames

John Reames

  • 348 Points 250 badge 2x thumb
???????
Photo of Kenny Mars

Kenny Mars

  • 1,224 Points 1k badge 2x thumb
I think the coffee is ready
Photo of Aaron Whitten

Aaron Whitten

  • 60 Points
Holy cow! I went thru the whole contact and warranty thing with ego. Got my new battery and plugged it into the charger...same issue!! Light flashes green for a few sec, then red light flashes and won’t charge. I read the above, tried placing on charger, then plugging in; didn’t work. Placed on charger, plugged in, then when the green light and fan first came on, dropped them together onto the hardwood floor from about 4”...bingo! Another fan came on as well and working like new!!
WTF??!!
Photo of Rusty Wyrick

Rusty Wyrick

  • 60 Points
My issue was the green light was immediately green with a dead battery. I had other chargers plugged into the same cord which apparently allowed the ego charger to draw a small amount of electricity. Unplugging the extension cord did nothing. Plugged the charger directly into its own outlet solved the issue and plugged it back in with others.
Photo of Joseph Maguire

Joseph Maguire

  • 94 Points 75 badge 2x thumb
My issue is slightly different.  The rapid charger says my 7.5Ah battery is fully charged, but dies on my self-propelled mower after 10-15 seconds, and the indicators on both the mower and the battery flash red.  Removing and reinserting the battery results in the same thing.  Popping it back on the charger shows all four bars as if it's fully topped-off.  My 2.5Ah battery charges and works fine.  I will first try the refrigerator trick and the "factory reset" trick before I start thinking what I was going to buy for $350 that will have to wait in order to buy a new battery.
Photo of Michael Schwartz

Michael Schwartz

  • 90 Points 75 badge 2x thumb
I plug the battery in to the charger and nothing...no fan or noise. Tried dropping it, plugging it in and out...nothing. Just green to yellow blinking to red on the battery and blinking 25% light on the charger. Anyone know what this means?
Photo of szwoopp

szwoopp, Champion

  • 111,634 Points 100k badge 2x thumb
Flashing red orange green is normal charging

Photo of Michael Schwartz

Michael Schwartz

  • 90 Points 75 badge 2x thumb
But no fan and has been plugged in for an hour an still blinking on 25%. Shouldn't the fan come on at some point?
Photo of szwoopp

szwoopp, Champion

  • 111,634 Points 100k badge 2x thumb
yes it should.  do you have another battery and or charger so you can switch around and determine which component is the issue ?
If not do you know someone else who has one?
If not do you have a store near by where you may be able to try this analysis ?

Try this
1) unplug charger
place battery on charger
plug charger in with battery in place.
This is a reboot procedure for the battery and charger - may work for you




Photo of Michael Schwartz

Michael Schwartz

  • 90 Points 75 badge 2x thumb
Thanks SZW,,,,tried all those things. No one I know has the same battery or charger. Whats interesting, is that when I first plug it in, the fan goes on for about 2 seconds and then stops. Thanks for trying to help. I really aprreciate it.
Photo of szwoopp

szwoopp, Champion

  • 111,634 Points 100k badge 2x thumb
What happens when you put the battery on the tool.

Call a local HD and see if they will let you come in and trouble shoot.  The rental dept is usually also the repair dept. 
Photo of Jessica Calles

Jessica Calles

  • 60 Points
This just happened to us yesterday as well. 
Photo of Michael Schwartz

Michael Schwartz

  • 90 Points 75 badge 2x thumb
So what did you do?

Photo of Charles

Charles

  • 300 Points 250 badge 2x thumb
Add me to the list of battery bangers.  My 2015 (or was it 2016) 5ah  quit charging in 2018. I set aside and bought a 2ah battery at local HD (only size they carried). Mowed with new 2ah and the one that came with chainsaw. Takes a little more than one 2ah to mow yard. Anyway, decided in spring 2019 to try charging 5ah battery again. It charged. Don't know if it was discharged enough (the 90+ day rest, self discharge) or if I dropped it, but it took a charge. Went to use 5ah in fall 2019, no charge. Saw this post and banged it one time, charged.  Still using Apr 2020.
Photo of Michael Thompson

Michael Thompson

  • 72 Points
I bought a new Ego mower last Spring. It ran and great all year. Love the mower!
We moved over the Winter season so the charger has been unplugged for awhile now.
There is no light at all in the indicator on the battery. I plugged the charger in. All 4 lights came on then went out. No fan. No indicator light on the charger. Is it possible that the battery is completely depleted and it will take awhile to get any kind of reading? The charger hasnt behaved like this before but this is my first time going through an off-season and coming back into use. It was partially charged when I bought it and the battery has never been completely depleted. Any help is greatly appreciated here.
(Edited)
Photo of Brandi Soldo

Brandi Soldo

  • 0 Points
Following. Same thing here! I had a great season with mine last year and the mower ran fine 2 weeks ago. But no light on the battery, now. The other day, on what I thought was a full charge, the mower would work for a while then die. Multiple times. I checked the battery on the charger and it lit up 100%. Ran the mower successfully for about 15 min. Then it would die. Checked battery again. It was fine (?). In the end, I figured it was a safety switch on the mower that needed attention. Gave it another shot today and the battery has no light and charger shows only the first LED (25%) but won't charge higher than that. Tried all the dropping and cajoling and paired outlet plugging to no avail. A separate but smaller 56V battery for which I have a separate charger works on this charger, shows the correct light sequences while on the charger, and runs the mower [should have checked that the other day!]. So the problem is definitely the 1.5 yr old battery. 
Photo of EZ

EZ

  • 0 Points
I have to say that this is one of the worst experience I had with any company. To get someone on the phone is impossible. In total of 5 days i think I left about 7 times a callback number after waiting on the line between 50-120 min each time. I Finally got one call back from Zakiya and she was trying to help (not so much), sent me email that require me to look for a receipt from 2 years ago that I could not locate. I sent her picture of the battery with the date marked on it (June 2018) but that is not enough for her. Ask to escalate, waited 20 min on the phone and she disconnected me. In overall, this battery worked for 1 time, then never recharged. Will never buy anymore any EGO Products.
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
so you bought it 2 years ago and have used it once ?

Where did you buy it
Did you use a credit card
Photo of EZ

EZ

  • 0 Points
yes, I bought it 2 years ago in November 2018. I used it once, and it was good . Charged it and it worked only for about 4-5 minutes. Then I put it in storage. Took it out and same...it will never work more than 3-4 minutes. And yes, I charged it overnight, over few days etc. I don't use it often as I have weekly lawn service at home.
Who keep receipt for 2 years? not me. and yes, bought it with CC, but how does it make any difference? CC will not show itemize details. It will show transaction. And that I provided to them, but still - no good.
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
Wow, you sat on this for 2 years before doing anything about it? What did you do in the meantime?
Photo of EZ

EZ

  • 0 Points
Read ^^^^ 
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
HD can sometimes get the receipt from their records

Ego may accept a CC record as proof of purchase.
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
Ok, I see your post above. You keep receipts for at least the warranty period in case you need to make a claim. Or, you register everything right away including uploading a copy of the receipt so you don't run into these kinds of problems. This is a very common way for manufacturers to honor their warranty program and EGO isn't the only one who does it.
Photo of EZ

EZ

  • 0 Points
@szwoopp, I provided CC record to them (in my response above), Still no good. 
@Oregon Mike, I usually register all my electronics etc. Not sure why I did not this time. In any case, I took pictures of the S/N and the battery dates on the battery that clearly state June 2018 (they claim battery have 3 years warranty). What more proof of that they need? Regardless, you all ignoring the fact that they have the most awful customer support experience.
I learn my lesson - pay more and buy reliable products from brand name you trust - No EGO
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
Battery warranty starts with day of purchase, not date of manufacture. So the info on the battery isn't useful from a warranty standpoint. Since you couldn't provide the correct info to EGO sounds like they did what they were supposed to do. No bad customer support there and most other manufacturers would have done the same if no proof of warranty coverage were provided. 
Photo of EZ

EZ

  • 0 Points
make no sense what you say whatsoever. either way it is not 3 years. my math say June 2018 should be at least good to June 2021 for 3 years warranty and for your knowledge we are now in May 2020.....
It seems that you just want to answer without reading. go find another place to respond if you don't really have anything to contribute.
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
I've been reading and comprehending and answering. I'll say it again, it does not matter that the date on the battery is less than 3 years old. Without proof of purchase, you have no warranty. That battery could have been resold, warranty is not transferable, along with many other possibilities that EGO would have no idea about. 
If your only intent is to complain, this isn't the place for that. If you were looking for reasons why or help with why EGO didn't honor your warranty, now you know. 
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
Yes the battery is not 3 year old.  Good there

But you could have bought it second hand or dug it out of the dumpster behind HD.
Thus you need proof of purchase.  It stinks to be without it, but that is what is required for warranty coverage.

And yes we are aware that their CS is currently overwhelmed.

Try requesting a copy of your receipt from HD.  They have been able to provide for others here with the same issue as you.
Photo of EZ

EZ

  • 0 Points
@Oregen Mike - go find a life, you are creepy person and not that smart, seems you are board and have no life.
@szwoopp. I don't buy second hand but regardless, warranty is warranty. also, read, I did provide CC statement of when I bought it, it is not HD statement therefore it is not itemized (it is showing HD purchase but not the items purchase). I will try contacting HD to see if they can help.
As for customer service overwhelmed...I understand it but they do not read the email the sent me and asked me to replay, when I get them again on the phone, then they read the email and when I wait online with Zakiya for supervisor, she disconnect me after 20 min waiting with her. That's not overwhelmed, that basic bad customer service
also when customer service overwhelmed it says alot about the product quality....
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
Well, I am retired, so I have lots of time on my hands. Not at all bored, though. It's a rainy day so I'm inside enjoying my time on EGO. I do find it interesting that you've decided to make things personal instead of keeping it on a more professional level. There really isn't anything else we can offer because we don't work for EGO and the problem has been answered as far as we know. Please report back with any further news that comes from EGO regarding your claim. Hope it works out for you.
If your only reason for being here is to make a complaint about customer service, that really isn't the reason for this forum. If so, time to move on.
Photo of EZ

EZ

  • 0 Points
good news- Daniel just call me and they processing replacement.
Photo of szwoopp

szwoopp, Champion

  • 116,054 Points 100k badge 2x thumb
That will even make Oregon Mike happy ;)
Photo of Oregon Mike

Oregon Mike, Champion

  • 83,354 Points 50k badge 2x thumb
The squeaky wheel. Glad EGO did right by you.