Battery no longer charges -- less than 6 months old

  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: customer service

I bought one of your ego 56 volt blowers last fall.  I went to use it this Spring (Atlanta, GA) and the following happened:  1) The battery still still had a charge from last fall (good news, I thought).  I did some work on the driveway and ran the battery out of juice.  i plugged the battery back in  and, the next day, when the light was green, I plugged the  battery back into the  blower and went back to work.  It didn't last too long, so I put it back in the charger.  Now, it  will not charge at all.  The light in the back end of the battery which used to  blink through 2 or  3 colors no longer comes on while it is charging.  The charger light  blinks red so i  know I am getting  juice to the charger..  If I push the button that lights up on the battery, it blinks red for a while and then goes out.  What is going on with  your battery???  Please respond  so I can get a bit more confidence back  on your products and service.  Thanks,  Frank 
Photo of Frank Larkin

Frank Larkin

  • 70 Points

Posted 3 years ago

  • 1
Photo of Samuel Strong

Samuel Strong

  • 2,060 Points 2k badge 2x thumb
Official Response
Hello Frank, 

As SCDC said, please call us. We do not show that you registered your products but, we'd be happy to assist you with the warranty and replacement process. We are available Monday through Friday 8:30AM-8PM EST and Saturdays and Sundays 10AM-6PM EST. We stand behind our products and will do what is necessary to make this right. Please have the serial numbers of your blower, battery, charger, and Home Depot proof of purchase ready when calling. We look forward to hearing from you.