Battery issues-resolved by accident

  • 8
  • Problem
  • Updated 2 weeks ago
  • Solved
  • (Edited)
Started mowing my yard and suddenly the battery went red after a few minutes. I removed the battery and placed it on the charger and it showed as fully charged. Tried again and after a few seconds it went red again and the mower quit.

I tried several options unplugging the charger, plugging it back in, etc. to no avail. Finally I thought if I could try and drain the battery maybe it would reset. I put it in the mower and ran it for a few seconds it died, waited re-did the process and figured it would take all day at that rate so I tried turning on the lights. They stayed on though the battery showed red.

After awhile I wanted to see if I could speed the process a little and tried starting the mower and you guessed it it worked. The battery continued to show red but finished the yard.

Before removing the battery I turned the lights off and then back on and the battery went to green. I put it on the charger and it is charging just fine.

Just thought I would relay my experience. Customer service was "in a staff meeting for the day" so were not able to assist.

A one time experience so far but if you find yourself in this situation try turning on the lights for a few minutes (mine were on about 30 minutes before I tried to start the mower) and see if it works.
Photo of Fred Herzer

Fred Herzer

  • 160 Points 100 badge 2x thumb

Posted 2 years ago

  • 8
Photo of Blue Angel

Blue Angel, Champion

  • 178,712 Points 100k badge 2x thumb
Official Response
Thanks for the feedback, it may help someone else with the same issue. Hopefully it doesn't happen again, but if it does let us know.