battery is stuck in line trimmer

  • 2
  • Problem
  • Updated 4 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I can not remove the battery from the line trimmer.  I have been using this for one year and it works great until now.  Please help.
Photo of Jerry Hershey

Jerry Hershey

  • 160 Points 100 badge 2x thumb

Posted 2 years ago

  • 2
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,632 Points 20k badge 2x thumb
Official Response
Here's one thing to try:
1) press the battery toward the trimmer head (same direction as inserting the battery),
2) while holding it in that position, please the release button.

I did a similar test where I pulled the battery in the removal direction, and when I tried to press the button, it was more difficult to get the latch to release.  When you do get it removed, double check the battery terminal lugs as well as the rails for any damage or foreign objects that would cause it to bind up.