Battery flashes green when plugged into mower

  • 1
  • Problem
  • Updated 4 weeks ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Hi, I purchased an Ego self propelled mower last week. I think 4/19/18. I used the mower and it worked great over that weekend. A week later I plugged in a fully charge battery. When I try to start the mower, the battery light flashes green and won't start. I've tried to plug it into the charger but it indicates it is fully charged. I've read through the battery literature but this problem is not addressed. Please help. Thanks. UPDATE- received a call from EGO and to the tech, it sounded like a circuit board issue. A "less than a percentage" problem that happens. Maybe I'll try the lottery today. I have to use my time to go return this product or have them send a new one in 4-5 days and not get my work done this weekend. That's not going to happen. Thank you EGO for not going above a beyond to make your costumer happy. No discount, no reimbursement for time and energy put into this. I'm a less than a percentage problem so who cares right?
Photo of Mike

Mike

  • 70 Points
  • angry

Posted 4 weeks ago

  • 1

There are no replies.

This conversation is no longer open for comments or replies.