Batteries not charging.

  • 2
  • Problem
  • Updated 3 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: out of date

So as of yesterday I have a total of 2 batteries that wont charge, they are about 2 yrs old, both batteries show a full charge( meaning green light is lite) I have a total of 6 batteries 3) 4.0 , 3) 2.0s, its one of the 2.0 and one 4.0, i haven't gave much thought to it because I cycle my batteries, once I get to the bad battery and it don't work I just skip it and reach for the next one, seems as a good time to tackle this issue. I have 4 chargers, so its not the charging system (ya i know i have a lot of chargers and batteries).......Any clue what I should do or how to fix........ to add the charger doesn't even start to cycle the charge(i think because it thinks its fully charged) to remind everyone i have 4 chargers so of course I tried to charge the bad batteries on all 4 chargers.
Photo of danl

danl

  • 192 Points 100 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Blue Angel

Blue Angel, Champion

  • 178,590 Points 100k badge 2x thumb
Official Response
danl, as long as you purchased everything from an authorized Ego retailer it will all be covered under the three year battery warranty.

Make sure all your serial numbers are registered and then send Ego an email with your contact information and a description of your issue. They'll get back to you and get everything sorted out ASAP:

support@egopowerplus.com