56v battery just continues to flash green..has been flashing green now for over 24 hours

  • 14
  • Problem
  • Updated 3 years ago
  • Acknowledged
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: duplicate

Got my chainsaw delivered on Tuesday from Home Depot..charged up the 56v battery no problem. Used the chainsaw for 20 minutes yesterday and worked fine but noticed while using that the battery was flashing green. Put it back on the charger and it continued to flash green. And it has continued to flash green for a full day. I can get it to stop flashing for a bout 10 seconds by holding light button down for a while but the light never goes off. Used it again this morning for 20 minutes and while using continued to flash green. Have disconnected battery from chainsaw and once again is still flashing green. Light never stops flashing green. On the charger it indicates battery is charged. Called EGO today and they have no history of this problem and gracefully agreed to replace the battery as it will eventually discharge on its own with the continued flashing. Searched the EGO community board and there is no information about this or anywhere online that I found. Wondering if anyone else has had this problem. Battery and chainsaw and charger are less than a week old...Glad EGO will replace the battery but would have appreciated a bit better quality control on their part.
Photo of Stephen Balberg

Stephen Balberg

  • 438 Points 250 badge 2x thumb
  • perplexed

Posted 4 years ago

  • 14
Photo of Jennifer VandeWater

Jennifer VandeWater, Community Manager

  • 81,028 Points 50k badge 2x thumb
Official Response
Stephen, thanks for giving us a chance to replace the battery for you.  That's definitely a new one for us and we're glad we can investigate it further.
Photo of David HD

David HD, Champion

  • 34,958 Points 20k badge 2x thumb
Official Response
BH, I also own a weed eater with great success thus far.  That said; I have never experienced this issue with my battery before, so the best recommendation is to call Customer Service (CS) in the morning. They will be able to help you with this issue.

Customer Service Department can be reached at 1-855-EGO-5656 (1-855-346-5656)
from 8:30AM - 8:00PM EST (Monday - Friday) and 10:00AM - 6:00PM EST (Saturday & Sunday).
(Edited)