16" Ego Chain Saw won't start anymore

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Duplicate

I bought the EGO 56V Li-Ion 16" Chain Saw on 02/24/17 and I have been really enjoying the saw until this weekend. The saw just randomly stopped working. I'm charged the battery tried a different battery and cleaned the bar and chain but without any luck. 
Photo of beelee51

beelee51

  • 84 Points 75 badge 2x thumb
  • frusterated

Posted 2 years ago

  • 1
Photo of (a)Typical Engineer

(a)Typical Engineer

  • 26,512 Points 20k badge 2x thumb

A few things you could try is: 1) double check the safety kick back guard to ensure it's all the way back, 2) remove the bar/chain, and see if it runs in that configuration (which would indicate some sort of stuck bar/chain combo), and 3) while you have the bar/chain off, does the motor sprocket rotate freely?


Photo of beelee51

beelee51

  • 84 Points 75 badge 2x thumb
Thanks for the advice, unfortunately I tired all of those things without anything. I am going to get a replacement part from my warranty.
Photo of Blue Angel

Blue Angel, Champion

  • 178,998 Points 100k badge 2x thumb
Give Customer Service a call.  They may have some troubleshooting steps to try out, but either way they'll get you fixed up.

This conversation is no longer open for comments or replies.