Conversations

Conversations 881 - 900 of 961
Photo of robert
EGO stopped cutting?
EGO stopped cutting? It started out fine and then stopped cutting suddenly. both blades are moving in the same direction so adjusting t...
  • 1 me too
  • 4 replies
  • Problem
  • Solved
  • Archived
Photo of Blue Angel
Like a Post From Email
Idea: offer multiple options in email notifications of forum activity Right now, when we get an email notification of a forum post in...
  • 1 me too
  • 4 replies
  • Idea
  • Under Consideration
  • Archived
  • Merged
Photo of Rob Falcipieri
First Cut and Thoughts
First cut, first impressions: Took advantage of the nice weather today and tried my new Ego LM2100 push mower, it was about 10:30A...
  • 2 me toos
  • 3 replies
  • Question
  • Doesn't Need an Answer
Photo of Ronald
NEED 3/4 INCH CUT CHOICE
LM2000S looks good. Almost there. However, I MUST have a 3/4 inch cut. Will you add a 3/4 inch cut to your cut choices with the hand le...
  • 1 me too
  • 8 replies
  • Idea
  • Under Consideration
Photo of Gregory
Mower - 26 minute run time?
I bought my mower 3 weeks ago.  It had a manufacture date of Feb 2013 which concerned me. It takes 45 minutes to cut my grass with a pus...
  • 1 me too
  • 8 replies
  • Problem
  • Solved
  • Archived
  • Merged
Photo of Joseph
battery+connection+wire+codes
I have a partially disassembled mower and need to know the color codes for reconnecting the battery compartment. The wires are colored bl...
  • 1 me too
  • 2 replies
  • Question
  • Doesn't Need an Answer
  • Archived
Photo of Ad Hoc
Just Bought It - Won't Turn On
I just bought this mower, took it out of the box, assembled and attached the bag, removed the discharge chute, plugged in the charger and...
  • 5 me toos
  • 8 replies
  • Problem
  • Solved
  • Archived