Conversations

Conversations 1 - 20 of 414
Photo of AJ
Not Mulching
I have an EGO 21" Self Propelled recently purchased from Home Depot.  I read and watched many reviews and was very excited to have a seem...
  • 4 me toos
  • 33 replies
  • Problem
  • Solved
  • Archived
Photo of JAS
15" Trimmer on order
Lost somewhere? Well my parents ordered me the 15" Trimmer on May 27 from Home Depot in Scottsbluff, NE. So far it hasn't showed up. Call...
  • 1 me too
  • 31 replies
  • Problem
  • Solved
Photo of Larry
The new 530CFM blower
The new 530CFM blower dead after about 20 minutes of use. Is anyone else having this problem? Was wondering if there is some type of des...
  • 2 me toos
  • 17 replies
  • Problem
  • Solved
Photo of Jim McD
Ego Mower Self-Propel issues
I’m really wanting to love Ego mowers, but they are making it difficult for me. Last May I purchased two 21” self-propelled mowers. One...
  • 3 me toos
  • 17 replies
  • Problem
  • Solved
  • Archived
  • Merged
Photo of Geoff
Home Depot repair issues
It appears EGO archived the prior discussion about long waits for repair of EGO mowers at Home Depot. As an update to my post a coupl...
  • 10 me toos
  • 16 replies
  • Problem
  • Solved
  • Archived
Photo of tinna
Help with batteries
Hi all. We just spent about 3000 $ on EGO products. I can say everything , just one missing (duo to no stock) to be all line. It was mor...
  • 1 me too
  • 16 replies
  • Problem
  • Solved
  • Archived
Photo of Al
Clippings being left behind
I recently purchased a 20" EGO mower and I've used it 3 times.  I always use the catch bag for clippings.  Each time I use the mower I no...
  • 2 me toos
  • 15 replies
  • Problem
  • Solved
  • Archived